Results 1 to 15 of 15

Thread: Evoco 10KW modification

  1. #1
    Fifer
    Guest

    Evoco 10KW modification

    Has anyone with an Evoco 10Kw had the yaw-damper fitted?
    How is the turbine working now?

  2. #2
    Windbreaker
    Guest

    Re: Evoco 10KW modification

    I am guessing not many from the amount of replies; Myself I am still waiting ;apparently the yaw damper is in the country but the ring that fits it onto the tower/ head is not. I already have the upgraded head since early Dec ( which was an improvement) so the modification should not take long either. just had a big electric bill which I thought I would not be getting for 20 years at least : 20 a day will help when it gets sorted

  3. #3
    Fifer
    Guest

    Re: Evoco 10KW modification

    I have just had the damper fitted but the turbine is not back up yet due to the discovery of a cracked blade.
    Turbine was just erected in Dec - I am just a bit nervous hence my query!!

  4. #4
    castell
    Guest

    Re: Evoco 10KW modification

    Quote Originally Posted by Fifer View Post
    I have just had the damper fitted but the turbine is not back up yet due to the discovery of a cracked blade.
    Turbine was just erected in Dec - I am just a bit nervous hence my query!!
    I had the damper fitted 3 weeks ago today, mine was only erected in Jan so I can't really comment as it was never turned on before the damper was fitted! It is in the same field as my Proven though and in light winds the Evoco will find the wind and get started quicker than the Proven, so I take it that the damper isn't impeding things anyway.
    Overall I am pleased with Evoco so far, as they have dealt with the problem quickly and seem to have good customer communication, having sent 2 letters out telling us what was going on.

  5. #5
    Fifer
    Guest

    Re: Evoco 10KW modification

    New blades fitted a few days ago, but due to clam conditions turbine only started tonight. Seems reluctant to turn downwind but once turning seems to keep going in low winds - it is still turning producing 0.5KW in very light wind.

  6. #6
    Fifer
    Guest

    Re: Evoco 10KW modification

    At last - leccy meter going backwards!

  7. #7
    salers
    Guest

    Re: Evoco 10KW modification

    Have you had the data logger installed.
    http://www.navitron.org.uk/forum/ind...c,16150.0.html

  8. #8
    Windbreaker
    Guest

    Re: Evoco 10KW modification

    Quote Originally Posted by salers View Post
    Have you had the data logger installed.
    http://www.navitron.org.uk/forum/ind...c,16150.0.html
    Where do you get that from; I definately need that !! ( although my wife would probably disagree; a combination of computers and turbines !!)
    My Evoco is back up and running again; seems to be working real smooth, be interesting to see it in gusty winds ; you could always see the original problem i.e. getting blown out of the wind and the stresses it put on the turbine.
    The last few months have been very interesting , with problems for all manufacturers ; but generally I am still happy with my choice.
    The warranty has been reset back to the start also ; i can see that issues with service/maintenance/insurance/reliability are going to become more relavant for everybody after the initial investment !

  9. #9
    salers
    Guest

    Re: Evoco 10KW modification

    Spoke to evoco today and they said that they got a few data loggers out on trials.They also said that youve got to have a extra cable to the turbine.

  10. #10
    Windbreaker
    Guest

    Re: Evoco 10KW modification

    oh well; not going to start digging again!(300 metres); thought it may be some kind of plug in / usb thingy to the inverter board.:cry:
    At least my wife will be pleased, although I do have that condition where you are looking at your generation and consumption meters all the time is it Meteritis ?:lolk:

  11. #11
    Penmoel
    Guest

    Re: Evoco 10KW modification

    Quote Originally Posted by salers View Post
    Spoke to evoco today and they said that they got a few data loggers out on trials.They also said that youve got to have a extra cable to the turbine.
    What kind of cable would that be Salers?

    Our foundation went in today and started the cable trench, is it worth me putting an extra cable of some sort in preparation ?

  12. #12
    Fifer
    Guest

    Re: Evoco 10KW modification

    I am not aware of data logger. Have just reinstated cable track so will not be digging it up again!
    Now have FiT payment registration confirmed with Scottish Gas, following delay after being told wrong email address by 'customer service'

  13. #13
    salers
    Guest

    Re: Evoco 10KW modification

    Quote Originally Posted by Penmoel View Post
    What kind of cable would that be Salers?

    Our foundation went in today and started the cable trench, is it worth me putting an extra cable of some sort in preparation ?
    I've been told its a thin data cable.I dont think it should be that expensive.
    Did you go for a Evoco turbine ?

  14. #14
    Penmoel
    Guest

    Re: Evoco 10KW modification

    Quote Originally Posted by salers View Post
    I've been told its a thin data cable.I dont think it should be that expensive.
    Did you go for a Evoco turbine ?

    Will have to finish laying cable tomorrow, did not go with Evoco in the end as Western Power would not let us, said their lines were not upto it and they had no intention of upgrading anytime soon, had to pay 4k to upgrade transformer even for a 5kw Evance.

    Lads who put the foundation in were due to go to you to set your Evoco back on track, they are coming back here on 27th are they going to you then?

  15. #15
    salers
    Guest

    Re: Evoco 10KW modification

    Yes they are coming to do my evoco that week.Bet you anything Lambing will be full swing that week.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •