Results 1 to 3 of 3

Thread: 5455 indicators

  1. #1
    Junior Member
    Join Date
    Oct 2013
    Location
    Randalstown
    Posts
    7

    5455 indicators

    Quick question. The indicators on my 2005 5455 have stopped working. Hazard lights are working fine. Any idea what fuse I need to check. I've opened fuse box and there's no fuse for indicators. Amy help appreciated

  2. #2
    Senior Member Footsfitter's Avatar
    Join Date
    Feb 2013
    Location
    Basingstoke, Hants
    Posts
    2,332

    Re: 5455 indicators

    Quote Originally Posted by Paul994 View Post
    Quick question. The indicators on my 2005 5455 have stopped working. Hazard lights are working fine. Any idea what fuse I need to check. I've opened fuse box and there's no fuse for indicators. Amy help appreciated
    Not familiar with that model but I would of guessed there should be fuses for indicators and/or hazards. Some designers used to use a hazard switch which controlled both indicators and hazards using just the one flasher unit, these were prone to long periods of not being switched and often loss of one or the other could be remedied by rapid use of the switch to get a contact again.

    Move on a bit and it became more common to have two circuits with two flasher units + switches, some interlinked and other not. The hazard supply will come from a permanent live supply, the flashers will come through a switched supply via the ign switch and possibly relays.


    Sorry to not be much help.
    The best thing about Facebook is the logout button......

  3. #3
    Senior Member T P's Avatar
    Join Date
    Feb 2013
    Location
    The muddy edge of the biggest puddle in the uk
    Posts
    599

    Re: 5455 indicators

    Fuse for indicators on 5400 series:

    https://ibb.co/kdKe7v

    https://ibb.co/fBp7ua

    https://ibb.co/gPYmLF

    All above assumes uk model,US / Canadian or German Italian import has different wiring for many things including roof indicators etc.

    Reading the schematic as FF suggested i'd be looking at the Hazard switch which should supply power out to the indicator switch on terminal 2 of CAB 43 (hazard switch) then via connection S13 to terminal 10 of CAB90 (indicator switch) and out of 8 or 9 to the lh rh bulbs as selected by the stalk.Alternatively look for power on terminal 10 of the indicator stalk and work from there.Try borrowing a hazard switch to see if that cures it or spray a load of contact cleaner into the hazard switch and switch it a lot. usually when the contacts get heated at a bad connection they are toast.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •