Results 1 to 7 of 7

Thread: Perkins 203 running rich.

  1. #1
    Senior Member
    Join Date
    Apr 2013
    Location
    CORNWALL
    Posts
    145

    Perkins 203 running rich.

    Hi all i have a perkins 203 engine that seems to be running rich on tickover, starts an go well but on tick over it is running harsh with a little grayish smoke but the funneyest thing is if i pull the lever on the lift pump she runs beautifilley with not a sign of smoke, it has the hydrulick govener on the pump as fitted to the perkins land rover conversions, thank you.

  2. #2
    Senior Member
    Join Date
    Feb 2013
    Posts
    1,203

    Re: Perkins 203 running rich.

    Has it got a heater unit supplied with fuel on the air intake manifold?

  3. #3
    Senior Member
    Join Date
    Apr 2013
    Location
    CORNWALL
    Posts
    145

    Re: Perkins 203 running rich.

    Quote Originally Posted by essexpete View Post
    Has it got a heater unit supplied with fuel on the air intake manifold?
    Yes it has but i have checked that by disconnecting it
    , any idea why it should run fine when i hold the lift pump primer lever up thanks for the reply.

  4. #4
    Senior Member
    Join Date
    Jan 2014
    Location
    NB Canada
    Posts
    595

    Re: Perkins 203 running rich.

    Quote Originally Posted by MISTERTUBBY2 View Post
    Yes it has but i have checked that by disconnecting it
    , any idea why it should run fine when i hold the lift pump primer lever up thanks for the reply.
    On gasoline engines, that is often the sign of an intake leak.

    Take a can of WD40 and spray some around the intake gaskets to see if there is a difference in how the engine runs (should start to smoke).

  5. #5
    Senior Member
    Join Date
    Apr 2013
    Location
    CORNWALL
    Posts
    145

    Re: Perkins 203 running rich.

    Quote Originally Posted by Ironhead View Post
    On gasoline engines, that is often the sign of an intake leak.

    Take a can of WD40 and spray some around the intake gaskets to see if there is a difference in how the engine runs (should start to smoke).
    Thanks for the reply ,this is a diesel engine i dont think your idea would work thanks anyway.

  6. #6
    Senior Member
    Join Date
    Apr 2013
    Location
    CORNWALL
    Posts
    145

    Re: Perkins 203 running rich.

    Quote Originally Posted by MISTERTUBBY2 View Post
    Thanks for the reply ,this is a diesel engine i dont think your idea would work thanks anyway.
    Found the problem it was the automatic advance retard unit on bottom of injector pump.

  7. #7
    Senior Member Footsfitter's Avatar
    Join Date
    Feb 2013
    Location
    Basingstoke, Hants
    Posts
    2,568

    Re: Perkins 203 running rich.

    Quote Originally Posted by MISTERTUBBY2 View Post
    Found the problem it was the automatic advance retard unit on bottom of injector pump.
    That makes sense. Good result then.
    The best thing about Facebook is the logout button......

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •