Results 1 to 6 of 6

Thread: JD 6620 power quad issue

  1. #1
    Junior Member
    Join Date
    Aug 2013
    Posts
    7

    JD 6620 power quad issue

    Hi,

    I am trying to sort out a strange problem with a power quad gearbox on a John Deere 6620 tractor.


    When the tractor is put into either A,B,C etc gears it lunges forward as if the Forward clutch is partially engaged. Due to this problem the forward clutch eventually failed and the clutch plates were replaced along with some seals and the forward and clutch solenoids were replaced at the same time in hopes that the problem would be fixed. The forward clutch rotated normally while the gearbox was open. Unfortunately the problem with the forward clutch has got worse when the tractor was re-started due to the new clutch plates.

    What could cause the forward clutch to be partially engaged when the tractor is running. Could it be a some sort of problem with the oil galleries in the gearbox cover.

    Regards
    Tom

  2. #2
    Senior Member Footsfitter's Avatar
    Join Date
    Feb 2013
    Location
    Basingstoke, Hants
    Posts
    2,694

    Re: JD 6620 power quad issue

    Quote Originally Posted by tommurphy73 View Post
    Hi,

    I am trying to sort out a strange problem with a power quad gearbox on a John Deere 6620 tractor.


    When the tractor is put into either A,B,C etc gears it lunges forward as if the Forward clutch is partially engaged. Due to this problem the forward clutch eventually failed and the clutch plates were replaced along with some seals and the forward and clutch solenoids were replaced at the same time in hopes that the problem would be fixed. The forward clutch rotated normally while the gearbox was open. Unfortunately the problem with the forward clutch has got worse when the tractor was re-started due to the new clutch plates.

    What could cause the forward clutch to be partially engaged when the tractor is running. Could it be a some sort of problem with the oil galleries in the gearbox cover.

    Regards
    Tom

    JD are not my cup of tea at all, but I would of thought you are looking at an internal leak of pressured oil getting into the forward clutch? The seals that you have replaced, are these all of the relevant internal seals? or just those disturbed during the repair? also a common trait nowadays seems to be cracked valve blocks allowing oil to leak internally, could be something like that? Have you tried pressure testing to see what pressures are in the forward clutch?
    The best thing about Facebook is the logout button......

  3. #3
    Junior Member
    Join Date
    Aug 2013
    Posts
    7

    Re: JD 6620 power quad issue

    We will be pressure testing tomorrow to see what is going on. I will update with the results.

  4. #4
    Senior Member wr.'s Avatar
    Join Date
    Feb 2013
    Location
    Breconshire
    Posts
    1,013

    Re: JD 6620 power quad issue

    How did you get on?
    Don't itch for something if you're not prepared to scratch for it.

  5. #5
    Junior Member
    Join Date
    May 2019
    Location
    Oxfordshire
    Posts
    2

    Re: JD 6620 power quad issue

    Check clutch cooling valve in transmission housing. Many times when tractor wants to drive sligtly forward when just range is selected springs are broken in cluch cooling valve. Should be cup - sping - spring support - spring - cup. When spring broken some oil pass and engage forward clutch

  6. #6
    Junior Member
    Join Date
    May 2019
    Location
    Oxfordshire
    Posts
    2

    Re: JD 6620 power quad issue

    Check Clutch cooling valve for broken springs.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •