Results 1 to 3 of 3

Thread: IH 674 problems

  1. #1
    Junior Member
    Join Date
    Jul 2019
    Location
    Cumbria
    Posts
    1

    IH 674 problems

    Hi there, I was hoping somebody out there may have had this problem and be able to offer some advice.
    I have an IH 674 and the power steering has stopped working. I have seen it suggested on several forums that you should check to see if it works when the auxiliary circuit is activated. I have tried this and sure enough, as soon as I put the auxiliary spool valve into lift, the power steering starts working like normal. Dose anybody know what fault this indicates? All the other hydraulic systems are working ok. I know that I should really be doing pressure and flow tests, but I don't have access to any test equipment.

  2. #2
    Senior Member Footsfitter's Avatar
    Join Date
    Feb 2013
    Location
    Basingstoke, Hants
    Posts
    2,708

    Re: IH 674 problems

    Quote Originally Posted by Dales_Dave View Post
    Hi there, I was hoping somebody out there may have had this problem and be able to offer some advice.
    I have an IH 674 and the power steering has stopped working. I have seen it suggested on several forums that you should check to see if it works when the auxiliary circuit is activated. I have tried this and sure enough, as soon as I put the auxiliary spool valve into lift, the power steering starts working like normal. Dose anybody know what fault this indicates? All the other hydraulic systems are working ok. I know that I should really be doing pressure and flow tests, but I don't have access to any test equipment.
    I'm really shooting in the dark here, experience with these is nearly zero but a quick google for a hydraulic circuit brings up this site- https://www.redpowermagazine.com/for...674-wont-move/

    The thread is about another type of fault but it shows diagrams that show the steering motor is supplied by a control valve. I expect that when you use the auxiliary valve it blocks or diverts oil forcing it to the steering motor. I'd be looking in this area for your problem?
    The best thing about Facebook is the logout button......

  3. #3
    Senior Member
    Join Date
    Feb 2013
    Location
    Co Down
    Posts
    479

    Re: IH 674 problems

    I'd suggest the priority valve in the mcv is stuck. If you look below the hyd filter but on the very bottom of the mcv block,there are 2 large plugs screwed up into the block. The one to the front contains the flow divider. There's a strong spring above the plug when you remove it,and then the flow divider valve body.The valve(spool) should slide out by itself.If not,long nose pliers should pull it out. If still not,put a bucket below and start the engine. If it still doesn't come out,it's stuck and will need freeing. It may be possible to tighten a rawl bolt in to give something to grip onto.When you do get it out,a rub with very,very fine emery should be enough to polish it to allow it to slide freely again.Also check the orifice in the valve is clear.
    If this doesn't sort it,you need to check the pressure at the ps ram hoses. Oh,and change the filter and be sure the mesh screen in there is clean as well.Be sure to reinsert the mesh back into the bowl before the filter and don't over tighten the bowl bolt.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •