Results 1 to 4 of 4

Thread: Matbro teleram not cutting silage

  1. #1
    Member
    Join Date
    Apr 2013
    Location
    co tyrone
    Posts
    72

    Matbro teleram not cutting silage

    Hi I have a 1985 matbro teleram it wonít cut the blocks out clean on the pit it would go half way and stop itís like she doesnít have enough pressure to cut any ideas?

  2. #2
    Senior Member ACE's Avatar
    Join Date
    Feb 2013
    Location
    Oxfordshire
    Posts
    1,596

    Re: Matbro teleram not cutting silage

    Quote Originally Posted by massey mad View Post
    Hi I have a 1985 matbro teleram it wonít cut the blocks out clean on the pit it would go half way and stop itís like she doesnít have enough pressure to cut any ideas?
    Test the pressure, its probably the pump worn out. or maybe your quick release fittings are incompatible.

    An old Teleram probably doesn't operate at the high pressure a more modern matbro does and even they are not that high so maybe you need a different attachment or its blunt!

  3. #3
    Junior Member
    Join Date
    Mar 2013
    Location
    northumberland
    Posts
    13

    Re: Matbro teleram not cutting silage

    Most likely blunt cutting blades, you can take the shoulder off the blades with a grinder but they need to be sharpened with a file or they won't cut. Dry silage is difficult to cut so keep it sharp.

  4. #4
    Member
    Join Date
    Apr 2013
    Location
    co tyrone
    Posts
    72

    Re: Matbro teleram not cutting silage

    It must be the pump on the matbro I put the shear grab on the tractor and it cut it really good. I tested the pressure on the matbro and it was around 2000 were the tractor was nearly 3000.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •