Results 1 to 11 of 11

Thread: New Holland TS110 lost power

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Junior Member
    Join Date
    Aug 2013
    Location
    Oklahoma, USA
    Posts
    9

    New Holland TS110 lost power

    Hello from the states. You fellas have more experience with New Holland than over here, and this tractor was mfd in Basildon. TS100 New Holland 2 WD tractor w/ 16x16 trans, cab w/air, & loader attached. Engine starts easily and seems to rev up to full throttle ok.. After about 10 minutes of running, under a light load it begins to pull down and acts as if there is no governor available. Tractor has 2293 hours and uses no oil. I have replaced the fuel lift pump twice in last week and replaced filters. It has a new Delphi inj pump installed at about 1550 hours, new fuel lift pump was installed at 1555 hours. Tractor is serviced and maintained regularly. When connected to 648 New Holland Baler, It will barely go up an incline when baling. When traveling in high gear on roadway, it will pull down to 1500 RPM on slight incline. Works fine for about 10 minutes after starting, then begins to have no power. After running about 30 minutes, I could lay my hand on the injector pump, but the fuel shutoff solenoid almost burned my finger. I have kept the filters changed and the fuel clean, so I cannot believe the pump needs rebuilding unless the Delphi pump is a pile of crap to start with. The original pump self destructed at 1550 hours, requiring a new pump. The load is not excessive as the tractor was pulling the same load fine 2 days earlier. I have sealed all possible leaks around the primary filter, and find no wet spots when pressurizing the tank. Is it possible that the shut off solenoid is bad since it is getting hot? I am about to pull the tank and check the intake line in the tank, it is all that is left.

  2. #2
    Senior Member
    Join Date
    Feb 2013
    Location
    Does unman yn debyg i adra
    Posts
    801

    Re: New Holland TS110 lost power

    If you suspect the fuel shut off solenoid then remove it, remove the plunger inside and re fit without plunger. You won't be able to stop engine with key then but will eliminate shut off solenoid.
    Ond lle bu'r arad' ar y ffridd Yn rhywgo'r gwanwyn pr o'r pridd

  3. #3
    Senior Member happy hillbily's Avatar
    Join Date
    Feb 2013
    Location
    Uwchaled, North Wales
    Posts
    160

    Re: New Holland TS110 lost power

    Vent for the fuel tank blocked ? Have seen a jd 6210 suck its tank in with the same problem. Does the fuel tank cap hiss if you open it after use ?

  4. #4
    Junior Member
    Join Date
    Aug 2013
    Location
    Oklahoma, USA
    Posts
    9

    Re: New Holland TS110 lost power

    Quote Originally Posted by happy hillbily View Post
    Vent for the fuel tank blocked ? Have seen a jd 6210 suck its tank in with the same problem. Does the fuel tank cap hiss if you open it after use ?
    I have blown air in the tank vent and in fact tried it with the tank vent open with no results> Thanks for the reply...

  5. #5
    Senior Member Footsfitter's Avatar
    Join Date
    Feb 2013
    Location
    Basingstoke, Hants
    Posts
    2,800

    Re: New Holland TS110 lost power

    Hello from the states. You fellas have more experience with New Holland than over here, and this tractor was mfd in Basildon.
    You'd be surprised from where over europe the parts come for Basildon to assemble!




    Quote Originally Posted by damengineer View Post
    I have blown air in the tank vent and in fact tried it with the tank vent open with no results> Thanks for the reply...

    Why not rule out the fuel tank/lines by rigging up a clean temporary fuel tank (ie- 25ltr drum?) and connecting it to the filter inlet/priming pump? See how it goes, but at least it will rule that out.

    Another "trick" is to insert a section of clear PVC hose on the pipe feeding the fuel pump, then you can see if there are bubbles from either a leak or if the feed is blocked, the injection pump is sucking hard enough to make a vacuum



    ff

  6. #6
    Senior Member
    Join Date
    Feb 2013
    Location
    Tasmania
    Posts
    1,129

    Re: New Holland TS110 lost power

    G'day Cecil

    haven't seen your name come up until now, so welcome to the BFF. You'll find a wealth of info here from the BFF Brains Trust.

    I'm not familiar with your tractor, but from my experience recently, it sounds like fuel starvation. My guess is a blockage of some sort, somewhere. Could be a mongrel to find, but I'd go with Footsfitter's suggestion of a temporary alternative fuel supply to progressively eliminate parts of the system.

    JV

  7. #7
    Senior Member
    Join Date
    Feb 2013
    Posts
    164

    Re: New Holland TS110 lost power

    I'd concur, we had the same trouble with an older IH. It would run great until the filter can was drained. By the time you'd take everything apart the filter was refilled from the tank. Found head of timothy hay in the suction line from tank with bunch of crap caught behind it. We had blown air back from filter to tank a couple of times that would fix it for a tank or two then the crap would suck back in.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •